use strict;
my $str = '90956780083
PR213328112
00000000000
00000000001
0000
123456789
1234
abc123
456456
987654321
3210
çá058
PR 213328112
PR.213328112';
my $regex = qr/^(?!(\d)\1{10,})(?=.*\d)[A-Za-z0-9]{11}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}