# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(\d)\1{10,})(?=.*\d)[A-Za-z0-9]{11}"
test_str = ("90956780083\n"
"PR213328112\n"
"00000000000\n"
"00000000001\n"
"0000\n"
"123456789\n"
"1234\n"
"abc123\n"
"456456\n"
"987654321\n"
"3210\n"
"çá058\n"
"PR 213328112\n"
"PR.213328112")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.