re = /^(?!(\d)\1{10,})(?=.*\d)[A-Za-z0-9]{11}/m
str = '90956780083
PR213328112
00000000000
00000000001
0000
123456789
1234
abc123
456456
987654321
3210
çá058
PR 213328112
PR.213328112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end