using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?!^\d+)^.*?)\:([a-zA-Z0-9_-]*)\b";
string input = @"123:12-nov-2021 07:00:00
date123:12-nov-2021 07:00:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}