const regex = /\b((?!^\d+)^.*?)\:([a-zA-Z0-9_-]*)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?!^\\d+)^.*?)\\:([a-zA-Z0-9_-]*)\\b', 'gm')
const str = `123:12-nov-2021 07:00:00
date123:12-nov-2021 07:00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}