re = /\b((?!^\d+)^.*?)\:([a-zA-Z0-9_-]*)\b/m
str = '123:12-nov-2021 07:00:00
date123:12-nov-2021 07:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end