import re
regex = re.compile(r"\b((?!^\d+)^.*?)\:([a-zA-Z0-9_-]*)\b", flags=re.MULTILINE)
test_str = ("123:12-nov-2021 07:00:00\n"
"date123:12-nov-2021 07:00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")