#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\[(([A-Za-zÀ-ú0-9_.]{1,}?)\.)([A-Za-z0-9À-ú_]{1,}?)\]\]"
Local $sString = "[[0_Th.corpus.à_la_findu_monde_et_avant]]" & @CRLF & _
"[[0_Th.res.corpus.été_indien]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")