const regex = /\[\[(([A-Za-zÀ-ú0-9_.]{1,}?)\.)([A-Za-z0-9À-ú_]{1,}?)\]\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[(([A-Za-zÀ-ú0-9_.]{1,}?)\\.)([A-Za-z0-9À-ú_]{1,}?)\\]\\]', 'gm')
const str = `[[0_Th.corpus.à_la_findu_monde_et_avant]]
[[0_Th.res.corpus.été_indien]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}