use strict;
my $str = '[[0_Th.corpus.à_la_findu_monde_et_avant]]
[[0_Th.res.corpus.été_indien]]';
my $regex = qr/\[\[(([A-Za-zÀ-ú0-9_.]{1,}?)\.)([A-Za-z0-9À-ú_]{1,}?)\]\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}