package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[(([A-Za-zÀ-ú0-9_.]{1,}?)\.)([A-Za-z0-9À-ú_]{1,}?)\]\]`)
var str = `[[0_Th.corpus.à_la_findu_monde_et_avant]]
[[0_Th.res.corpus.été_indien]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}