#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)\<body[^\>]*\>(.*)\<\/body\>"
Local $sString = "" & @CRLF & _
"<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0">" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="ie=edge">" & @CRLF & _
"</head>" & @CRLF & _
"<body class="text">" & @CRLF & _
" <div class="container">" & @CRLF & _
" <header><h1>This is a test</h1></header>" & @CRLF & _
" </div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")