package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)\<body[^\>]*\>(.*)\<\/body\>`)
var str = `
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
</head>
<body class="text">
<div class="container">
<header><h1>This is a test</h1></header>
</div>
</body>
</html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}