const regex = /\<body[^\>]*\>(.*)\<\/body\>/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<body[^\\>]*\\>(.*)\\<\\\/body\\>', 'si')
const str = `
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
</head>
<body class="text">
<div class="container">
<header><h1>This is a test</h1></header>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}