import re
regex = re.compile(r"\<body[^\>]*\>(.*)\<\/body\>", flags=re.DOTALL | re.IGNORECASE)
test_str = ("\n"
"<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
"<head>\n"
" <meta charset=\"UTF-8\">\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"ie=edge\">\n"
"</head>\n"
"<body class=\"text\">\n"
" <div class=\"container\">\n"
" <header><h1>This is a test</h1></header>\n"
" </div>\n"
"</body>\n"
"</html>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")