re = /\<body[^\>]*\>(.*)\<\/body\>/i
str = '
<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
</head>
<body class="text">
<div class="container">
<header><h1>This is a test</h1></header>
</div>
</body>
</html>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end