const regex = /[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}', 'gm')
const str = `You could put your Package ID below, if it is highlighted that means it matches the pattern.
KOjpdB613k.MyTestID`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}