$re = '/[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}/m';
$str = 'You could put your Package ID below, if it is highlighted that means it matches the pattern.
KOjpdB613k.MyTestID';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);