import re
regex = re.compile(r"[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}", flags=re.MULTILINE)
test_str = ("You could put your Package ID below, if it is highlighted that means it matches the pattern.\n\n"
"KOjpdB613k.MyTestID")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")