// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}").unwrap();
let string = "You could put your Package ID below, if it is highlighted that means it matches the pattern.
KOjpdB613k.MyTestID";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}