re = /[0-9a-zA-Z]{10}[.][0-9a-zA-Z]{1,52}/m
str = 'You could put your Package ID below, if it is highlighted that means it matches the pattern.
KOjpdB613k.MyTestID'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end