using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})[\.\s]?(\d{3})[\.\s]?(\d{3})[-\s]?(\d{2})";
string substitution = @"The CPF: $1.$2.$3-$4";
string input = @"CPF for Regular Expressions:
89812312545
898 123 125 45
898.123.125-45";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}