re = /(\d{3})[\.\s]?(\d{3})[\.\s]?(\d{3})[-\s]?(\d{2})/m
str = 'CPF for Regular Expressions:
89812312545
898 123 125 45
898.123.125-45'
subst = 'The CPF: $1.$2.$3-$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result