# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{3})[\.\s]?(\d{3})[\.\s]?(\d{3})[-\s]?(\d{2})"
test_str = ("CPF for Regular Expressions:\n\n"
"89812312545\n"
"898 123 125 45\n"
"898.123.125-45")
subst = "The CPF: $1.$2.$3-$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.