import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3})[\\.\\s]?(\\d{3})[\\.\\s]?(\\d{3})[-\\s]?(\\d{2})";
final String string = "CPF for Regular Expressions:\n\n"
+ "89812312545\n"
+ "898 123 125 45\n"
+ "898.123.125-45";
final String subst = "The CPF: $1.$2.$3-$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}