const regex = new RegExp('^(?:\\D+)?(?:(?:[4-7](?:(?:\\.|\\,)[1-9])?)|(?:[5-8](?:(?:\\.|\\,)0)?))(?:(?:\\s?gb)|\\s?giga|\\sgigabyte)?(?:.*)', 'si')
const str = `4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)
\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:"|''|\\x60|'|´|”)
(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)
(4(?:\\.|\\,)[1-9])(.*) => 4-5
(5(?:\\.|\\,)[0]))(.*) => 4-5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}