use strict;
my $str = '4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)
\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:"|\'\'|\\x60|\'|´|”)
(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)
(4(?:\\.|\\,)[1-9])(.*) => 4-5
(5(?:\\.|\\,)[0]))(.*) => 4-5';
my $regex = qr`^(?:\D+)?(?:(?:[4-7](?:(?:\.|\,)[1-9])?)|(?:[5-8](?:(?:\.|\,)0)?))(?:(?:\s?gb)|\s?giga|\sgigabyte)?(?:.*)`sip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}