import Foundation
let pattern = #"^(?:\D+)?(?:(?:[4-7](?:(?:\.|\,)[1-9])?)|(?:[5-8](?:(?:\.|\,)0)?))(?:(?:\s?gb)|\s?giga|\sgigabyte)?(?:.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
4.5 polegadas (~ 64,3% relação tela-corpo)
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
5"-6" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3
^(?:(6(?:\.|\,)0)|(5(?:\.|\,)[1-9]))(.*)
\s?(?:(?:\d+)(?:\.|\,)?(?:\d+)?)(?:"|''|\x60|'|´|”)
(?:(5(?:\.|\,)0)|(4(?:\.|\,)[1-9]))(.*)
(4(?:\.|\,)[1-9])(.*) => 4-5
(5(?:\.|\,)[0]))(.*) => 4-5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}