using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)?(?:|[^\/]+)(?:|\/)$";
string input = @" site.loc/product/7-hello-world/65-gtyjkj45545/543-5454";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}