const regex = /(\d+)?(?:|[^\/]+)(?:|\/)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)?(?:|[^\\\/]+)(?:|\\\/)$', '')
const str = ` site.loc/product/7-hello-world/65-gtyjkj45545/543-5454`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}