$re = '/(\d+)?(?:|[^\/]+)(?:|\/)$/';
$str = ' site.loc/product/7-hello-world/65-gtyjkj45545/543-5454';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);