package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)?(?:|[^\/]+)(?:|\/)$`)
var str = ` site.loc/product/7-hello-world/65-gtyjkj45545/543-5454`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}