# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\$item_#1_Value\$\s*/1234/gi;t' <<< "ABC$item_#1_Value$QWERT
Ax. BC $ITEM_#1_VALUE$ QWERT
ABC $item_#1_Value$ QWERT"