re = /\s*\$item_#1_Value\$\s*/i
str = 'ABC$item_#1_Value$QWERT
Ax. BC $ITEM_#1_VALUE$ QWERT
ABC $item_#1_Value$ QWERT'
subst = '1234'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result