using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\$item_#1_Value\$\s*";
string substitution = @"1234";
string input = @"ABC$item_#1_Value$QWERT
Ax. BC $ITEM_#1_VALUE$ QWERT
ABC $item_#1_Value$ QWERT";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}