package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s*\$item_#1_Value\$\s*`)
var str = `ABC$item_#1_Value$QWERT
Ax. BC $ITEM_#1_VALUE$ QWERT
ABC $item_#1_Value$ QWERT`
var substitution = "1234"
fmt.Println(re.ReplaceAllString(str, substitution))
}