$re = '/\s*\$item_#1_Value\$\s*/i';
$str = 'ABC$item_#1_Value$QWERT
Ax. BC $ITEM_#1_VALUE$ QWERT
ABC $item_#1_Value$ QWERT';
$subst = "1234";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;