package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[9][2-5]\d{7}`)
var str = `929164344
915392194
943757798
922955344
914094882
990824719
991259647
925212121
954000000
964000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}