import re
regex = re.compile(r"[9][2-5]\d{7}", flags=re.MULTILINE)
test_str = ("929164344\n"
"915392194\n"
"943757798\n"
"922955344\n"
"914094882\n"
"990824719\n"
"991259647\n"
"925212121\n"
"954000000\n"
"964000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")