// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[9][2-5]\d{7}").unwrap();
let string = "929164344
915392194
943757798
922955344
914094882
990824719
991259647
925212121
954000000
964000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}