const regex = /@(\"[\w\s-]+\")|(?!@([\w-]+)@([\w-]+))@([\w-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(\\"[\\w\\s-]+\\")|(?!@([\\w-]+)@([\\w-]+))@([\\w-]+)', 'g')
const str = `There is @key-1 apples on the table.
There is @"key1" apples on the table.
There is @key 4 apples on the table.
There is @"key 4" apples on the table.
There is @key@key2 apples on the table.
There is @key3 apples on the table. (second step)
There is @"key @"key3"" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3 " apples on the table.
There is @"key 4 " apples on the table. (second step)
There is @"key-@"key-3@key7"" apples on the table.
There is @"key-@"key-32"" apples on the table. (second step)
There is @"key-21" apples on the table. (3rd step)
There is @key@key2@key3@key4 apples on the table.
There is @key@key2@key35 apples on the table. (second step)
There is @key@key26 apples on the table. (3rd step)
There is @key7 apples on the table. (4th step)
There is @key-5 apples on the table.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}