re = /@(\"[\w\s-]+\")|(?!@([\w-]+)@([\w-]+))@([\w-]+)/
str = 'There is @key-1 apples on the table.
There is @"key1" apples on the table.
There is @key 4 apples on the table.
There is @"key 4" apples on the table.
There is @key@key2 apples on the table.
There is @key3 apples on the table. (second step)
There is @"key @"key3"" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3 " apples on the table.
There is @"key 4 " apples on the table. (second step)
There is @"key-@"key-3@key7"" apples on the table.
There is @"key-@"key-32"" apples on the table. (second step)
There is @"key-21" apples on the table. (3rd step)
There is @key@key2@key3@key4 apples on the table.
There is @key@key2@key35 apples on the table. (second step)
There is @key@key26 apples on the table. (3rd step)
There is @key7 apples on the table. (4th step)
There is @key-5 apples on the table.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end