use strict;
my $str = 'There is @key-1 apples on the table.
There is @"key1" apples on the table.
There is @key 4 apples on the table.
There is @"key 4" apples on the table.
There is @key@key2 apples on the table.
There is @key3 apples on the table. (second step)
There is @"key @"key3"" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3" apples on the table.
There is @"key 4" apples on the table. (second step)
There is @"key @key3 " apples on the table.
There is @"key 4 " apples on the table. (second step)
There is @"key-@"key-3@key7"" apples on the table.
There is @"key-@"key-32"" apples on the table. (second step)
There is @"key-21" apples on the table. (3rd step)
There is @key@key2@key3@key4 apples on the table.
There is @key@key2@key35 apples on the table. (second step)
There is @key@key26 apples on the table. (3rd step)
There is @key7 apples on the table. (4th step)
There is @key-5 apples on the table.
';
my $regex = qr/@(\"[\w\s-]+\")|(?!@([\w-]+)@([\w-]+))@([\w-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}