# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@(\"[\w\s-]+\")|(?!@([\w-]+)@([\w-]+))@([\w-]+)"
test_str = ("There is @key-1 apples on the table. \n"
"There is @\"key1\" apples on the table. \n"
"There is @key 4 apples on the table.\n"
"There is @\"key 4\" apples on the table.\n\n"
"There is @key@key2 apples on the table.\n"
"There is @key3 apples on the table. (second step)\n\n"
"There is @\"key @\"key3\"\" apples on the table.\n"
"There is @\"key 4\" apples on the table. (second step)\n\n"
"There is @\"key @key3\" apples on the table.\n"
"There is @\"key 4\" apples on the table. (second step)\n\n"
"There is @\"key @key3 \" apples on the table.\n"
"There is @\"key 4 \" apples on the table. (second step)\n\n"
"There is @\"key-@\"key-3@key7\"\" apples on the table.\n"
"There is @\"key-@\"key-32\"\" apples on the table. (second step)\n"
"There is @\"key-21\" apples on the table. (3rd step)\n\n"
"There is @key@key2@key3@key4 apples on the table.\n"
"There is @key@key2@key35 apples on the table. (second step)\n"
"There is @key@key26 apples on the table. (3rd step)\n"
"There is @key7 apples on the table. (4th step)\n\n"
"There is @key-5 apples on the table.\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.