#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@e(?!ureka\.com).?u.?r.?e.?k.?a\.com"
Local $sString = "jcarter@eurreka.com" & @CRLF & _
"jcarter@euureka.com" & @CRLF & _
"jcarter@eurekaa.com" & @CRLF & _
"jcarter@eeureka.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")