$re = '/@e(?!ureka\.com).?u.?r.?e.?k.?a\.com/m';
$str = 'jcarter@eurreka.com
jcarter@euureka.com
jcarter@eurekaa.com
jcarter@eeureka.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);