re = /@e(?!ureka\.com).?u.?r.?e.?k.?a\.com/m
str = 'jcarter@eurreka.com
jcarter@euureka.com
jcarter@eurekaa.com
jcarter@eeureka.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end