using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@e(?!ureka\.com).?u.?r.?e.?k.?a\.com";
string input = @"jcarter@eurreka.com
jcarter@euureka.com
jcarter@eurekaa.com
jcarter@eeureka.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}