#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)0x(([[:xdigit:]]{7}\b)|([[:xdigit:]]{6}\b)|([[:xdigit:]]{5}\b)|([[:xdigit:]]{4}\b)|([[:xdigit:]]{3}\b)|([[:xdigit:]]{2}\b)|([[:xdigit:]]{1}\b))"
Local $sString = "{0x1023350, 0x3014}," & @CRLF & _
"{0x1023954, 0x3007}," & @CRLF & _
"{0x1023960, 0x10F}," & @CRLF & _
"{0x102396C, 0x2FF}," & @CRLF & _
"{0x10219, 0x16},"
Local $sSubst = "0x(?{2}0)(?{3}00)(?{4}000)(?{5}0000)(?{6}00000)(?{7}000000)(?{8}0000000)${1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)