import re
regex = re.compile(r"0x(([[:xdigit:]]{7}\b)|([[:xdigit:]]{6}\b)|([[:xdigit:]]{5}\b)|([[:xdigit:]]{4}\b)|([[:xdigit:]]{3}\b)|([[:xdigit:]]{2}\b)|([[:xdigit:]]{1}\b))", flags=re.MULTILINE)
test_str = ("{0x1023350, 0x3014},\n"
"{0x1023954, 0x3007},\n"
"{0x1023960, 0x10F},\n"
"{0x102396C, 0x2FF},\n"
"{0x10219, 0x16},")
subst = "0x(?{2}0)(?{3}00)(?{4}000)(?{5}0000)(?{6}00000)(?{7}000000)(?{8}0000000)${1}"
result = regex.sub(subst, test_str)
if result:
print(result)